1. <u id="epx8e"></u>
        <u id="epx8e"><sub id="epx8e"></sub></u>

        
        
        <video id="epx8e"><big id="epx8e"></big></video>

        <i id="epx8e"><bdo id="epx8e"><delect id="epx8e"></delect></bdo></i>
        0712-2888027 189-8648-0214
        微信公眾號

        孝感風信網絡科技有限公司微信公眾號

        當前位置:主頁 > 技術支持 > PHP > This package requires php ^7.1.3 but your PHP version (7.0.12) does not satisfy that requirement錯誤的解決

        This package requires php ^7.1.3 but your PHP version (7.0.12) does not satisfy that requirement錯誤的解決

        時間:2024-04-22來源:風信官網 點擊: 7751次
        風信建站Laravel項目開發過程中,在初始化項目過程中This package requires php ^7.1.3 but your PHP version (7.0.12) does not satisfy that requirement錯誤的解決方法:

        分析:以下錯誤為php版本太低導致,所以我們需要清理composer.lock文件。

        解決方法是:

        刪除 composer.lock 文件,重新執行 composer install,這樣就能重新生成 composer.lock 文件了。

        $ laravel new katCMS
        Crafting application...
        Loading composer repositories with package information
        Installing dependencies (including require-dev) from lock file
        Your requirements could not be resolved to an installable set of packages.

          Problem 1
            - This package requires php ^7.1.3 but your PHP version (7.0.12) does not satisfy that requirement.
          Problem 2
            - Installation request for doctrine/inflector v1.3.0 -> satisfiable by doctrine/inflector[v1.3.0].
            - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 3
            - Installation request for laravel/framework v5.6.26 -> satisfiable by laravel/framework[v5.6.26].
            - laravel/framework v5.6.26 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 4
            - Installation request for symfony/console v4.1.1 -> satisfiable by symfony/console[v4.1.1].
            - symfony/console v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 5
            - Installation request for symfony/css-selector v4.1.1 -> satisfiable by symfony/css-selector[v4.1.1].
            - symfony/css-selector v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 6
            - Installation request for symfony/debug v4.1.1 -> satisfiable by symfony/debug[v4.1.1].
            - symfony/debug v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 7
            - Installation request for symfony/event-dispatcher v4.1.1 -> satisfiable by symfony/event-dispatcher[v4.1.1].
            - symfony/event-dispatcher v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 8
            - Installation request for symfony/finder v4.1.1 -> satisfiable by symfony/finder[v4.1.1].
            - symfony/finder v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 9
            - Installation request for symfony/http-foundation v4.1.1 -> satisfiable by symfony/http-foundation[v4.1.1].
            - symfony/http-foundation v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 10
            - Installation request for symfony/http-kernel v4.1.1 -> satisfiable by symfony/http-kernel[v4.1.1].
            - symfony/http-kernel v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 11
            - Installation request for symfony/process v4.1.1 -> satisfiable by symfony/process[v4.1.1].
            - symfony/process v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 12
            - Installation request for symfony/routing v4.1.1 -> satisfiable by symfony/routing[v4.1.1].
            - symfony/routing v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 13
            - Installation request for symfony/translation v4.1.1 -> satisfiable by symfony/translation[v4.1.1].
            - symfony/translation v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 14
            - Installation request for symfony/var-dumper v4.1.1 -> satisfiable by symfony/var-dumper[v4.1.1].
            - symfony/var-dumper v4.1.1 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 15
            - Installation request for doctrine/instantiator 1.1.0 -> satisfiable by doctrine/instantiator[1.1.0].
            - doctrine/instantiator 1.1.0 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 16
            - Installation request for myclabs/deep-copy 1.8.1 -> satisfiable by myclabs/deep-copy[1.8.1].
            - myclabs/deep-copy 1.8.1 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 17
            - Installation request for nunomaduro/collision v2.0.3 -> satisfiable by nunomaduro/collision[v2.0.3].
            - nunomaduro/collision v2.0.3 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 18
            - Installation request for phpunit/php-code-coverage 6.0.7 -> satisfiable by phpunit/php-code-coverage[6.0.7].
            - phpunit/php-code-coverage 6.0.7 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 19
            - Installation request for phpunit/php-file-iterator 2.0.1 -> satisfiable by phpunit/php-file-iterator[2.0.1].
            - phpunit/php-file-iterator 2.0.1 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 20
            - Installation request for phpunit/php-timer 2.0.0 -> satisfiable by phpunit/php-timer[2.0.0].
            - phpunit/php-timer 2.0.0 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 21
            - Installation request for phpunit/php-token-stream 3.0.0 -> satisfiable by phpunit/php-token-stream[3.0.0].
            - phpunit/php-token-stream 3.0.0 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 22
            - Installation request for phpunit/phpunit 7.2.6 -> satisfiable by phpunit/phpunit[7.2.6].
            - phpunit/phpunit 7.2.6 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 23
            - Installation request for sebastian/comparator 3.0.1 -> satisfiable by sebastian/comparator[3.0.1].
            - sebastian/comparator 3.0.1 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 24
            - Installation request for sebastian/diff 3.0.1 -> satisfiable by sebastian/diff[3.0.1].
            - sebastian/diff 3.0.1 requires php ^7.1 -> your PHP version (7.0.12) does not satisfy that requirement.
          Problem 25
            - laravel/framework v5.6.26 requires php ^7.1.3 -> your PHP version (7.0.12) does not satisfy that requirement.
            - laravel/tinker v1.0.7 requires illuminate/console ~5.1 -> satisfiable by laravel/framework[v5.6.26].
            - Installation request for laravel/tinker v1.0.7 -> satisfiable by laravel/tinker[v1.0.7].

        Application ready! Build something amazing.
        熱門關鍵詞: package requires php 7.1.3 PHP version
        欄目列表
        推薦內容
        熱點內容
        展開
        亚洲AV无码乱码国产精品桃色_国产欧美亚洲精品第二区软件_精品亚洲AV无码国产一区在线_老熟妇乱子伦中文观看_日韩 欧美 亚洲 精品 少妇_日本按摩高潮A级中文字幕免费观看